Getting Spoilt – MacBook Air edition

In July, I splurged and bought a Mac Book Air. My MacBook pro was a little aged, and I wanted to go for a smaller, lighter laptop, yet I didn’t want to go too small. Plus I am a Mac person.

I have been using it pretty heavily, and it has been super solid. It has enough storage, it is fast enough, and while I would like the retina display, I am really grooving on the 12+ hours of battery life I am getting on it.

My macbook pro is semi-permanently attached to a sweet 24″ monitor, and my Drobo for backups, and the Mac Book Air is my walking around computer.

This last weekend, I was moving websites to my new hosting account (see ‘A Bad Day – Webhosting“) , so I unplugged the MBP and relocated to the couch. Oh. My. God. That thing is friggin HUGE compared to the Air. Yes, it is a 15″, and it is from the generation before the Retina display, but compared to the Air, it is heavy, huge, and cumbersome (it also has a quadcore processor, 16G ram, and a terabyte of disc).

It honestly felt how I thought a 17” laptop felt. Too big.

Nope, I don’t think I will be going back to that monstrosity. It will remain my stationary system until it dies, then I will probably replace it with a Mini.

What a way to waste a Sunday – troubleshooting edition

On our trip last week, my wife (again) dropped her laptop. After that, it stopped working. Oops.

First thoughts were that it was a failed hard drive. All my utilities failed to find it. So I replaced it with a known good drive.

It had a clean install of OS X Lion on it, and was pretty lightly used before I replaced it. I know it was good.  The system wouldn’t boot.  So I thought maybe that the install didn’t support her older laptop. So out came the Snow Leopard (10.6) install DVD. It failed to install. It found the drive ok, but it couldn’t properly access it. No way to write to it, and diskutility was unable to unmount the drive.

Out it goes, and back into an external case and off to my main mac. No problems, the drive behaves as expected.

Crap.

Take the original drive and put it into the external case (a generic OWC FW800 enclosure), and bam, the system boots off it fine.

So, it is either in the drive cable (unlikely) or the system Logic Board (much more likely).

Alas, it is beyond my ability to troubleshoot, or repair, so off to Apple for my wife. But I spent about a half a day fiddling with it. Oh well.